# 常见问题

# composer

composer dump-autoload 之后,很可能会出现

Your Composer dependencies require a PHP version ">= 7.4.0". You are running 7.3.24.

这样的错误,由于版本的问题导致不可用。有两种解决方式

  • 升级 PHP 版本
  • 使用 composer 配置
    • composer.json 文件中配置
{
    "config": {
        "platform-check": false
    }
}
  • 单独项目配置: composer config platform-check false
  • 全局配置: composer global config platform-check false

配置完成之后,重新 composer dump-autoload